Nanowii "vergisst" ACC Kalibrierung

User helfen User!

Nanowii "vergisst" ACC Kalibrierung

Postby Dremel » 15 Jun 2015 19:10

Moin zusammen,
ich habe vor ca. 1 Monat meinen 2. Quadrocopter fertiggestellt.
Geworden ist es ein 250er Rennsemmel mit einer Nanowii.
Fernbedienung ist eine Futaba T10j.
Multiwii V 2.4

Das Problem:
Im Acro Mode fliegt sich die Nanowii recht gut.
Schalte ich das ACC nach einem Lipowechsel an, stürzt er regelmäßig ab.
ACC mittels Gui kalibrieren und mittels Funke nachjustieren --> geht wieder
Nach unbestimmter Zeit schalte ich im Flug ACC wieder an --> Absturz.
Beim Absturz kippt der Kopter nicht immer über die selbe Seite: Mal flipt er nach hinten, mal eine Rolle über rechts.....
Wie gesagt, im ACC ist alles gut.

Bis jetzt habe ich Folgendes versucht.
Die Funke neu kalibriert. Wenn die Sticks in Mittelstellung sind, habe ich einen Wert von 1500,
Stickendstellung 1000 und 2000. Das war´s nicht, aber wie gesagt, im Acro alles o.k..

Das ACC habe ich mit Wasserwaage mehrmals kalibriert (mittels GUI). Dann noch nachkalibriert mittels Funke.
Hiernach "merkt" sich die Nanowii die ACC Kalibrierung für eine unbestimmte Zeit.

Eeprom gelöscht.
Verschiedene Versonen der Multiwii aufgespielt (nach Löschen der eeprom)
Config h nach Fehlern durchsucht, aber nix passendes gefunden (Quad X, Nanowii .... scheint zu passen)
Propeller entwuchtet, fest
Nanowii nochmal "doppelt" gedämpft gelagert
Mit dem Lowpassfilter herumgespielt
Nach Anstecken des Lipo´s die Nanowii für 15 Sec. nicht bewegt und dann erst losgeflogen
Die PID-Werte nochmals optimiert (obwohl es daran eigentlich nicht liegen kann.)

Ich habe das Problem in verschiedenen Foren gefunden, aber keiner hatte am Ende eine Lösung.
Ich bin echt verzweifelt.
Ich habe mir sogar eine zweite Nanowii gekauft, wo das Problem auch auftritt :shock:
Befestige ich meine Multiwii Se 2.5 am Quad, funktioniert alles tadellos.

Meine jetzigen 2 Theorien:
1) Auf dem Nanowii ist eine fehlerhafte Charge von ACC´s verbaut, was ich aber nicht glaube/hoffe, da ansonsten
viel mehr in den Foren los sein müsste.
2) Ich habe irgendwo einen dummen Fehler, den ich aber nicht sehe

Vielleicht wisst Ihr weiter. Ich möchte einfach ruhig schlafen (und nicht immer über das Problem nachdenken).
Und ich will Fliegen!

Habt Ihr einen Tipp?
Grüße vom Dremel
Dremel
 
Posts: 4
Joined: 15 Jun 2015 18:24

Re: Nanowii "vergisst" ACC Kalibrierung

Postby pic18f2550 » 15 Jun 2015 23:18

ACC vor dem Start schon aktiviert?
Schmiert der Copter dann beim wiedereinschalten ab?

Teste mal ob bei der 2.4 auch auftrit.
42 ist die Antwort auf die gestellte Frage „nach dem Leben, dem Universum und dem ganzen Rest“.
pic18f2550
 
Posts: 284
Joined: 05 Sep 2014 14:47

Re: Nanowii "vergisst" ACC Kalibrierung

Postby Dremel » 16 Jun 2015 05:57

Wenn ich Acc vor dem Start aktiviere tritt das Problem auch auf, nur dass ich da ja merke, dass was nicht stimmt. Wenn ich dann ACC kalibrieren isses wieder gut.
Aber auch nicht immer. Ich kann den Fehler nicht nach belieben reproduziere. Es muss ja was mit der eeprom sein.......
Aber wenn der Kopter denken würde, dass er total schief steht, dann dürfte ich ihn ja auch nicht armen können ?!!
Bei der 2.4 tritt es auch auf......
Dremel
 
Posts: 4
Joined: 15 Jun 2015 18:24

Re: Nanowii "vergisst" ACC Kalibrierung

Postby pic18f2550 » 05 Jul 2015 10:17

Welche GUI nimmst Du?
Die für Crome oder die MultiWiiConfig?

Schließ das USB-Kabel von der NanoWii zum PC an. (kein LIPO oder was anderes)
Kalibriere mal die ACC mit der GUI und trenne danach das Kabel zum PC. ( Also die Nanowii 10 sec ohne Strom)
Schließ das USB-Kabel von der NanoWii zum PC wieder an und Prüfe ob die NanoWii immer noch die richtigen Werte zeigt.
42 ist die Antwort auf die gestellte Frage „nach dem Leben, dem Universum und dem ganzen Rest“.
pic18f2550
 
Posts: 284
Joined: 05 Sep 2014 14:47

Re: Nanowii "vergisst" ACC Kalibrierung

Postby Dremel » 05 Jul 2015 18:09

Ich nehme die MultiwiiConfig.
Bis jetzt habe ich ACC dort nur für
die "grobe" Justierung genommen und die Feinjustierung
über die Funke (disarm,full throttle....) gemacht.

Jetzt fällt mir auf, dass wenn ich mit der GUI ACC kalibriere, sich die nick-Achse immer bei -1 einstellt und sich nicht auf 0 stellt....
Auch wenn ich den Kopter absichtlich "schief" kalibriere stellt er sich nicht auf 0 , sondern auf -1.
(Habe auch mal eeprom gecleart, aber irgendwie geht er nicht auf 0 ).
Diese Einstellung merkt er sich aber....
mh.....
Dremel
 
Posts: 4
Joined: 15 Jun 2015 18:24

Re: Nanowii "vergisst" ACC Kalibrierung

Postby pic18f2550 » 05 Jul 2015 22:00

:?: :!: :?: komisch :?:

kannst Du mir mal dein Sketch schicken?

Und mir eventuel ein paar Hinweise geben wo Du was eingestellt hast.
42 ist die Antwort auf die gestellte Frage „nach dem Leben, dem Universum und dem ganzen Rest“.
pic18f2550
 
Posts: 284
Joined: 05 Sep 2014 14:47

Re: Nanowii "vergisst" ACC Kalibrierung

Postby pic18f2550 » 08 Jul 2015 23:34

Gerade gefunden

The table below shows the cross-axis sensitivity as a percentage of the gyroscope or accelerometer’s
sensitivity for a given orientation error, respectively.
Cross-Axis Sensitivity vs. Orientation Error
Orientation Error
Cross-Axis Sensitivity
(θ or Φ) (sinθ or sinΦ)
0 0%
0.5 0.87%
1 1.75%
The specifications for cross-axis sensitivity in Section 6.1 and Section 6.2 include the effect of the die
orientation error with respect to the package.

also 0,78% würde mit dem Anzeigewert von 1 übereinstimmen.
Da müsste noch eine offsetberechnung in den sketch hinein.
42 ist die Antwort auf die gestellte Frage „nach dem Leben, dem Universum und dem ganzen Rest“.
pic18f2550
 
Posts: 284
Joined: 05 Sep 2014 14:47

Re: Nanowii "vergisst" ACC Kalibrierung

Postby Dremel » 13 Jul 2015 18:55

Moin,

einen MAG habe ich nicht (NAnowii 1.0) , war im Sketch so glaube ich drin.
Habe MAG rausgenommen, jedoch keine Besserung.
Mit Änderung von X,Y,Z Achse sollte alles so stimmen. -Z funktioniert nicht.

Über den letzten Post muss ich erstmal nachrecherieren.
Bin gerade etwas beruflich eingespannt.

Vielen Dank für den Input.
Dremel
 
Posts: 4
Joined: 15 Jun 2015 18:24

Re: Nanowii "vergisst" ACC Kalibrierung

Postby pic18f2550 » 13 Jul 2015 20:54

Willkommen im Club.
Ich geistere auch die nächsten Monate außerhalb rum. (460km)
Das sich die Werte. nicht speichern lassen ist schon komisch.
Den Taster auf dem Bord drückst du aber nicht?
Da wird nämlich alles zurück gesetzt.
Das clerEEPROM löscht glaub ich nur 512byts der FC hat wenn ich mich richtig erinnere 1k.
Ob das was ausmacht weis ich nicht.
42 ist die Antwort auf die gestellte Frage „nach dem Leben, dem Universum und dem ganzen Rest“.
pic18f2550
 
Posts: 284
Joined: 05 Sep 2014 14:47


Return to Probleme

Who is online

Users browsing this forum: No registered users and 1 guest

cron